pacotes.eletrotupi.com

ref: master

pkgs/smithy/APKBUILD


# Maintainer: Pedro Lucas Porcellis 
pkgname=smithy
pkgver=0.2.1
pkgrel=5
pkgdesc="A tiny git forge written in Go"
options="!check" # No testsuite
url="https://github.com/honza/smithy"
arch="all"
license="GPLv3"
subpackages="$pkgname-openrc"
makedepends="git go"
install="$pkgname.pre-install"
options="!check" # no test suite
source="
	$pkgname-$pkgver.tar.gz::https://github.com/honza/smithy/archive/v$pkgver.tar.gz
	$pkgname.initd
	$pkgname.confd
	fallback-to-user-default-monospace-font.patch
"
pkggroups="smithy"
builddir="$srcdir/$pkgname-$pkgver"

build() {
	make smithy
	make smithy.yml
}

package() {
	install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname

	install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
	install -Dm644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}
sha512sums="
89c4242ea3bbdbcd8ee9f035bbb0665d2197f11282cd2b8c963759edad5c7c703d772ea1f6f10283040a3b7dd8495aa78b862b7e8409dd1f7d5dfa0eec09ef68  smithy-0.2.1.tar.gz
a7c415023ad45be5c7badb50f97275f46b38a19399f229b3408875ebd5811293b4efec5766716fa8dc0447be0995a3f6964b1b851c6d71960a3ab3e3d0b2f588  smithy.initd
f78e8fd5e8de95313df23ee2b292dabd7645d9bfbbbce5fcecdd3961bd8cf5e06c3a6e7294a04061b3c46ece29465a911fb313810e55acaf5fa67adda04020e3  smithy.confd
3788e8e24be104549ada666d6df2bff0142d91bc40d4f082ddade1add0ee6d4e97283891a0c9542091a28f6fbcb0d155ba81784f73138932ba4484febd2df887  fallback-to-user-default-monospace-font.patch
"